Welcome to Suzuki Club SG

Suzuki Club SG is the official club for all current & previous owners of Suzuki cars in Singapore. SIGN UP FOR YOUR FREE ACCOUNT TODAY!

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join us today!


Author Topic: Water pump  (Read 4401 times)

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Water pump
« on: August 24, 2016, 01:45:14 AM »
Seen the service manual, I think after every 80k if this part needs inspection or probably replacement. Anyone has done it before? Can advise?

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Re: Water pump
« Reply #1 on: August 24, 2016, 10:00:50 PM »
Was quoted dis lists for water pump related replacements for SX4. Anyone can advise? ???

Offline admin

  • Administrator
  • 1st Gear
  • *****
  • Posts: 284
  • Points: +1/-1
    • View Profile
    • Suzuki Club Singapore
Re: Water pump
« Reply #2 on: August 24, 2016, 11:37:21 PM »
Yes, most people do this together with the timing belt service. I believe 100k mileage will be the big service. Most Suzuki pro shop can do this big service around $1,000.

What is your mileage now?

Offline admin

  • Administrator
  • 1st Gear
  • *****
  • Posts: 284
  • Points: +1/-1
    • View Profile
    • Suzuki Club Singapore
Re: Water pump
« Reply #3 on: August 24, 2016, 11:37:56 PM »
Wow that price is not too bad. You are also doing oil/transmission oil/coolant/spark plug service with the timing belt service ya?

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Re: Water pump
« Reply #4 on: August 25, 2016, 11:13:00 PM »
I'll do a wait n see monitor 1st lah... would check engine temp and coolant level remains norm till year end. There's something else im lookin at, like engine vibrations.. recently change all 4 engine mounts but still has little vibs when coming to stop. But nil vibs when put to N while waiting lights go green. Any thoughts abt this issue? ???

Offline admin

  • Administrator
  • 1st Gear
  • *****
  • Posts: 284
  • Points: +1/-1
    • View Profile
    • Suzuki Club Singapore
Re: Water pump
« Reply #5 on: August 26, 2016, 11:51:10 AM »
I'll do a wait n see monitor 1st lah... would check engine temp and coolant level remains norm till year end. There's something else im lookin at, like engine vibrations.. recently change all 4 engine mounts but still has little vibs when coming to stop. But nil vibs when put to N while waiting lights go green. Any thoughts abt this issue? ???

Did you change the transmission mounts as well?

Offline chaselim

  • 1st Gear
  • *
  • Posts: 286
  • Points: +5/-1
    • View Profile
Re: Water pump
« Reply #6 on: August 26, 2016, 06:10:49 PM »
I'll do a wait n see monitor 1st lah... would check engine temp and coolant level remains norm till year end. There's something else im lookin at, like engine vibrations.. recently change all 4 engine mounts but still has little vibs when coming to stop. But nil vibs when put to N while waiting lights go green. Any thoughts abt this issue? ???
Your SX4 have 4 engine mounting?
A good tuning car must be something that you can take out to the streets.  The car must be fun, fast and safe on all kinds of road conditions.

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Re: Water pump
« Reply #7 on: August 26, 2016, 07:21:38 PM »
Yes chaselim. 4 of them. My ride is SX4 1.6A VVT sedan.

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Re: Water pump
« Reply #8 on: August 26, 2016, 07:23:29 PM »
Transmission mounts? Never thought of it.  ???

Offline Yippe

  • 1st Gear
  • *
  • Posts: 63
  • Points: +0/-0
  • Front Strut / Rear Anti-Roll Bar / K&N / Volt Stb.
    • View Profile
  • Suzuki(s) Owned: SX4HB
Re: Water pump
« Reply #9 on: August 27, 2016, 09:17:33 AM »
I'll do a wait n see monitor 1st lah... would check engine temp and coolant level remains norm till year end. There's something else im lookin at, like engine vibrations.. recently change all 4 engine mounts but still has little vibs when coming to stop. But nil vibs when put to N while waiting lights go green. Any thoughts abt this issue? ???

Did you change the transmission mounts as well?


bro, I think that Vibration with Aircon (700 RPM) its normal. when put to "N" Vib. go away, mine ride same too.
if OFF Aircon no Vib at stop right?
what I do is to use Carb. spray and clean the throttle valve.everthing get well again. cheers

Offline R4zzy

  • 1st Gear
  • *
  • Posts: 34
  • Points: +1/-0
    • View Profile
  • Suzuki(s) Owned: Sx4 sedan
Re: Water pump
« Reply #10 on: August 28, 2016, 11:36:07 AM »
I do worry abt touching throttle body. Kakis mentioned this thing sensitive and rather not meddle with it.

 

SimplePortal 2.3.6 © 2008-2014, SimplePortal